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1.0 Executive Summary and Introduction 

This report describes the efforts and outcomes of a project begun in April 2017 and concluded in 

July 2019 to develop dynamic traffic assignment (DTA) tools for the Regional Transportation 

Commission (RTC) of Southern Nevada. The DTA models cover the RTC Regional Travel Demand 

(TDM) model’s entire modeling domain area, which includes the City of Las Vegas, the City of 

North Las Vegas, the City of Henderson, the unincorporated Clark County areas within the Las 

Vegas Valley, and the core of Boulder City. Caliper Corporation, the developers of the software 

platforms TransCAD and TransModeler on which the models are built, created two DTA models 

for the RTC: 

One DTA model is implemented in TransDNA, a mesoscopic DTA built on the TransCAD 

platform and leveraging much of the same data and geography that drive the RTC’s 

TransCAD travel demand model. This mesoscopic DTA provides a rapid DTA for region-wide 

applications for which operational fidelity and accuracy can be sacrificed for quicker 

responses to longer-range or more planning-oriented decision-making. 

The second DTA model is implemented in TransModeler and uses high-fidelity microscopic 

traffic simulation to model traffic flow throughout the region. This microscopic DTA more 

reliably and accurately addresses operational concerns, predicting operating capacity and its 

influence on congestion patterns and, consequently, route choices. 

Both  DTA models include every street that is included in the RTC planning model, but many 

additional streets are added to the microscopic DTA in TransModeler in order to capture the 

effects of all signalized intersections in the region, without which traffic models of all kinds risk 

underestimating travel times and delays on arterials. DTA scenarios were developed for the AM 

peak (6:00 AM – 9:00 AM) and PM peak (1:00 PM – 6:00 PM) periods. 

The DTA model was calibrated to verify that the model’s trip patterns (e.g., temporal distribution 

of departure times) reflected historical traffic count data and validated to verify that the model’s 

simulated travel times matched closely with measured travel times and speeds. This report details 

the steps taken and assumptions made in the development of the DTA models, briefly describes 

the calibration methods, reports the validation results, and illustrates how to use the models. 
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2.0 Model Development 

The Dynamic Traffic Assignment (DTA) model in TransModeler was developed from the input data 

described below. The lane-level road network was first developed almost entirely from scratch 

using high-resolution aerial imagery as a guide. Centroids and centroid connectors were imported 

from the regional travel demand model (TDM) to ensure consistency in the IDs of traffic analysis 

zone (TAZ) centroids that serve as the origins and destinations of trips generated by the RTC’s 

regional travel demand model. The common TAZ and centroid representation is the primary link 

between the travel demand and DTA models and allows for the ready sharing of trip matrices. 

The highly accurate road network was subsequently exported to create a line layer for TransDNA 

that included fields describing left- and right-turn bay lengths and their number of lanes. The 

development of the TransModeler database is described in the remainder of this section. 

2.1 Data Sources 
A variety of data are required to build DTA models. At a minimum, these data include aerial 

imagery to build the geography and geometry of the street network, signal timing data with 

which to simulate the operations of signalized intersections, and traffic count/speed data by short 

time interval to calibrate the model. General Transit Feed Specification (GTFS) data may be used 

to import transit route information into the model. Other types of data, such as detailed traffic 

counts and travel time measurements, are used for validating the model. The DTA model for the 

RTC was developed from the following data sources: 

▪ Aerial imagery freely available from web map services like Google 

▪ Signal timings provided by the RTC 

▪ Traffic count data provided by the RTC 

▪ Speed data from INRIX 

▪ Google travel times 

▪ GTFS data 

2.2 Model Design 
TransModeler, in which the DTA model was developed, and TransCAD, in which the regional TDM 

is built, share a common representation of origins and destinations, both in the form of TAZ IDs. 

This common identification of trip origins and destinations allows trip matrices generated by the 

TDM to be used as input to the DTA model and simulated. 

The DTA model includes every street that is in the regional TDM planning model network. Many 

other streets were added so that all signalized and other major intersections that could be 

discerned from aerial imagery were included.  

In addition to their use as a reliable traffic model for traffic impact assessment, there are other 

substantial benefits to DTA models that are worth mentioning. The DTA model’s Geographic 

Information System (GIS) and relational database platform make the model a powerful, lane-

level repository of traffic data. Specifically, the model can be used as a database to store and 
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update geographic and geometric information. Additionally, the model can also serve as a signal 

timing inventory for the RTC region to complement the tools that the Freeway & Arterial System of 

Transportation (FAST) maintains. Finally, the platform also provides an integrated GIS-3D 

modeling environment that can be leveraged to visualize scenarios and to facilitate public and 

stakeholder involvement in the project evaluation process.  

2.3 Street Network Development 
The geographic line layer representing the road network in a TDM in any planning software 

platform can be used to generate a preliminary simulation database in TransModeler. Hence, the 

planning network for the RTC’s model in TransCAD was a potential resource for creating the 

simulation database for the DTA model. However, road editing and network development tools in 

TransModeler have made it cost-effective to develop networks for entire metropolitan areas by 

hand over high-resolution aerial imagery, a process that lends itself to other important network 

development tasks, such as identifying bus and HOV lanes and signalized intersections that may 

not be in the planning network. The simulation database for the RTC planning region was thus 

created. Additional streets were added to cover all signalized intersections that were identifiable 

in the imagery.  Other tools, such as Google Earth and Google Street View, were used to confirm 

important geometric details such as lane utilization and turn prohibitions at intersections. 

TransModeler provides built-in access to web map services that allow map content such as 

Google Maps, Google Satellite, OpenStreetMap, and USGS Topographic Maps to be 

downloaded automatically to the map window. Aerial imagery from these web-based sources 

was used to determine roadway, intersection, and interchange geometry. Where construction was 

visible in the imagery or roadway projects were known or suspected to have occurred in recent 

years, historical imagery or other web-based sources were used to determine 2015 geometry. 

At the conclusion of the development of the street network, error-checking routines in 

TransModeler were used to scan the database for common coding errors. This ensured that there 

were no missing lane connections, unnecessarily short segments, or errors in intersection or 

roadway geometry. Other coding errors were encountered and corrected as the model’s 

development and the calibration of the model progressed. 

2.3.1 Geometric Detail 

Very little geometric detail is spared in the DTA model. A point of emphasis in the model’s 

development was to achieve a highly accurate representation of intersection shape and 

dimension, which to a large degree govern an intersection’s or interchange’s operting capacity. In 

addition to the geometric shapes (e.g., horizontal curvatures) of intersecting streets, effort was 

made to accurately represent turn bay lengths, lane widths, turn lane channelization, vehicle 

trajectories through intersections, and other geometric elements. Figure 2-1 and Figure 2-2 

demonstrate the level of detail in the model at two locations in the RTC region.  
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Figure 2-1. Interchange at I-15 and W. Flamingo Road 

 
Figure 2-2. A pair of roundabouts along N. Town Center Drive  
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2.3.2 Roadway Functional Classification 

Determining and applying the appropriate roadway functional class to links in TransModeler has 

an important influence on driver behavior and route choice in the model. The speed limit is the 

most important road class attribute in the microscopic simulation model. A driver’s desired speed, 

the speed at which the driver will travel in the absence of the influence of traffic signals or other 

vehicles, is a function of the speed limit, with more conservative drivers adhering closely to the 

speed limit and more aggressive drivers traveling faster.  

Road class and speed data from the 2015 Amendment 1 TDM model network were used to 

assign road classes to all applicable roads in the simulation model. The functional class of roads in 

the DTA model that were not included in the TDM model were estimated. Figure 2-3 shows a line 

representation of the street network color-coded by road class in the DTA model.  
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Figure 2-3. Map of street network color-coded by functional class 

2.4 Traffic Control Input Development 
Traffic signals are crucial to traffic operations on surface streets, and the DTA model has a 

detailed representation of traffic signal timings accurate enough to support what-if scenario 

evaluation with a high degree of operational sensitivity. The model can support analysis of transit 

signal priority, train pre-emption, and various other traffic signal timing strategies. 

Signal timing data, including timing data at ramp meters, were provided by FAST. RTC staff also 

assisted in providing additional data on phase assignment (e.g., Phase 1 serves the EBL 

movement) that were not available in many of the signal timing spreadsheets. Of the 1,437 
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signalized intersections in the study area, 1,414 were FAST signals and 1,060 had available 

signal timing data that were imported. The signal timings at the remaining 377 signals were 

estimated based on projected 2015 peak period turning movement demand, common signal 

timing parameters in the area, and engineering judgment. Throughout the network, actuated 

signal operations were assumed and simple detector geometries, with stop-bar call and extension 

detection, were applied.  

There are 68 ramp meters in the study area. Timing parameters were obtained for 38 of those 

locations and were assumed for the remainder.  At ramp meters for which no data were 

available, traffic-responsive operations were assumed to be running during the most common 

times of day (6:00 AM – 9:00 AM and 3:00 PM – 6:00 PM) with the typical occupancies and 

rates provided to us by the RTC. Queue detectors were also assumed to be operational, and if 

the queue occupancy was exceeded, ramp metering was assumed to be turned off. 

A map illustrating the locations of ramp meters is provided in Figure 2-4, and a map illustrating 

the locations of signalized intersections in the model is provided in Figure 2-5.  

 
Figure 2-4. Map of ramp meter locations in the DTA model 
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Figure 2-5. Map of signalized intersection locations in the DTA model 

2.5 Traffic Count Data 
Traffic count data were obtained for the entire study area from five sources:  

1. Nevada Department of Transportation (NDOT) short-term 15-minute counts 

2. Express lane counts 

3. ATR counts 

4. Southern Nevada Traffic Study (SNTS) counts in 15-minute bins for three locations 
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a. I-15 
b. I-215 
c. Summerlin Parkway 

5. FAST detector data (counts and speeds) in 15-minute bins 

The simulation database, which is the geo-relational database that stores the geography and 

geometry of the street network, is populated with these count data, and our calibration analyses 

focus on these data in coordination with the speed data discussed below. Express lane counts 

were unfortunately unusable for the purposes of calibration because volumes were not 

differentiated by lane. Counts that conflicted with one another were also discarded as they would 

adversely affect the calibration process.  

For example, in this location along I-515 NB, we have four count locations and the total PM peak 

period (2:00 PM – 6:00 PM) volumes are labeled below. If you start from the east and go west, 

19,390 – 2,047 exiting at the off ramp + 4,466 entering the on ramp = 21,809. Yet the count in 

orange is only 17,407. Other neighboring counts agree with the 19,390 count so we weighted the 

17,407 count with a zero weight. 

 
Figure 2-6. Example of count location weighted zero 

In all, there were 939 valid counts for the AM period and 954 valid counts for the PM period 

used for calibration distributed throughout the region. Figure 2-7 illustrates the locations of counts 

throughout the network. Counts are associated with segments in the model. Although it is difficult 

to identify individual counts, Figure 2-7 gives a sense of the roughly even distribution of the counts 

throughout the network. 
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Figure 2-7. Count locations 
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Figure 2-8. Count locations near the Strip and Airport 
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2.6 Speed Data 
Speed data are critical to understanding where bottlenecks occur in the network. INRIX is a global 

Software as a Service (SaaS) and Data as a Service (DaaS) company that provides roadway 

speed data from mobile phones, connected vehicles, trucks, and fleet vehicles equipped with GPS 

devices. INRIX speed data from Wednedays between March 1, 2016 and May 31, 2016 were 

obtained and averaged to use in the calibration process. 

2.7 Travel Time Data 
In order to validate the model, we obtained sample travel time data using Google’s Directions 

API (application programming interface), one of a variety of web services offered through the 

Google Maps Platform. The Directions API license that was used limits the number of queries that 

can be submitted per day. We selected centroids of 59 TAZs distributed throughout the network, 

making sure to select at least two TAZs per K-District. The locations of the 59 origin TAZ centroids 

are shown in Figure 2-9. 
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Figure 2-9. Locations of TAZ Centroids in Sample for Google Travel Times 

We then queried travel times with those 59 centroids serving as the origins to all 1,658 centroids 

as the destinations (97,822 OD pairs) every half hour during the AM and PM model periods. Thus, 

travel times for 97,822 OD pairs were queried for 8 departure times: 7:00 AM, 7:30 AM, 8:00 

AM, 8:30 AM, 2:00 PM, 2:30 PM, 3:00 PM, 3:30 PM, 4:00 PM, 4:30 PM, 5:00 PM, and 5:30 PM. 

Since data cannot be queried in the past, we queried a typical spring day, Wednesday, April 

10, 2019.  

We also queried some data (7:30 AM, 8:00 AM, 4:00 PM, 4:30 PM, 5:00 PM, 5:30 PM) on 

Wednesday, July 17, 2019 to see if travel times fluctuated throughout the year. We found that 

travel distances stayed exactly the same 68-75% of the time, indicating the same route was 

likely assumed by Google during both months. When the travel distance was the same, the travel 

times were very similar in April and July, as shown by the scatterplots in Figure 2-10. Even when 
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the travel distance was not the same, the travel times were still very similar with only a few 

instances of significantly different travel times (Figure 2-11). 

 

 
Figure 2-10. Scatterplots Comparing Google Travel Times when Travel Distances are the Same 
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Figure 2-11. Scatterplots Comparing Google Travel Times when Travel Distances are Different 

The sample of Google travel times was narrowed to internal-to-internal (II) OD pairs whose entire 

paths, both according to Google and to the model, would traverse links inside the model. Given 

that, 88% of AM simulated OD pairs and 87% of PM simulation OD pairs in the respective 15-

minute departure interval had a corresponding Google travel time with which to compare. The 

resulting scatterplots are available in Section 4.0 Validation. 

2.8 GTFS Data 
We added transit routes to the network using GTFS data publicly available from 

https://transitfeeds.com/p/rtc-southern-nevada/47. To represent 2015 service, we downloaded 

the February 4, 2015 data and imported Service ID 4_merged_357527228, which ran from 

February 22, 2015 to November 7, 2015. This resulted in 212 transit routes being added to the 

network as shown in Figure 2-12. 
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Figure 2-12. Imported transit routes 

2.9 TransDNA Model Development 
For the mesoscopic DTA in TransDNA, a line layer was derived from the simulation network 

developed for the DTA in TransModeler and described earlier in Section 2.3. Hence, the line 

layer contains all the roadway links in the TransCAD planning model but has the same added 

street and centroid connector detail that is needed to support simulation and DTA. In other words, 

all geometric enhancements made to the TransModeler network are therefore reflected in the 

TransDNA line layer. These enhancements include the addition of fields in the line layer to 

represent the presence of left-turn and right-turn bays, number of turn bay lanes, and turn bay 

lengths. These fields are important inputs to TransDNA, in which the influence of turn bays on 

traffic flow can be reasonably well captured without the need to split links when the lane 

configuration changes. 

The representation of intersection geometrics as line layer attributes also has the advantage of 

minimizing the number of links in the network, enabling simulation with low running times. Greater 

numbers of links increase running times because they slow down shortest path calculations, which 

take longer as the number of nodes traversed increases and which are performed many times 

over in the course of a DTA in order to update route choices as congestion patterns evolve. 
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3.0 Calibration 

Calibration and validation of the TransModeler DTA model were aimed at achieving (1) 

confidence that the DTA model and its underlying traffic flow model are capable of reflecting 

2015 conditions, including regional traffic patterns and bottleneck locations, and (2) confirmation 

that the model is properly coded and that signal timing estimations and centroid connectivity are 

reasonable. Key results from this effort, such as the time-varying origin-destination (OD) flows, 

were later used as inputs to the TransDNA DTA model. 

3.1 Driver Behavior Adjustments 

3.1.1 Vehicle Class Distribution 

The vehicle class distribution defines the mix of vehicle types (e.g., auto, SUV/pickup, truck, etc.) 

to be simulated. Data from the 2013 On-Road Vehicle Classification Study were used to calculate 

AM and PM peak period vehicle class distributions.  

3.1.2 Freeway Transfer Penalties 

TransModeler has route choice parameters that assign a penalty for movements entering or 
exiting the freeway. These parameters are meant to deter paths that may leave the freeway on 
an exit ramp and immediately return on an entrance ramp. However, these penalties can also 
deter reasonable route choices, such as paths that enter the freeway only to travel on it for a 
very short distance before leaving on the next exit ramp. In our calibration efforts, we saw 
arterials being underutilized versus freeways. In an effort to balance demand for paths utilizing 
freeways and the local street network, freeway transfer penalties were increased to 60 seconds 
for exiting the freeway and 120 seconds for entering the freeway. 

3.1.3 Centroid Connector Travel Time Error 

Like all regional models, the microsimulation model does not simulate within-zone traffic and thus 

may not accurately depict the starting points of trips at centroid origins, nor the ending locations 

of trips at centroid destinations. In some zones, there are large numbers of centroid connectors. A 

centroid connector at the origin and at the destination must be either randomly assigned 

according to weights, a method that has a variety of problems (e.g., infeasible or unreasonable 

paths may result in some situations), or chosen as part of the route choice calculation.  

Like travel times and delays on road segments, travel times can be assigned to centroid 

connectors, and those travel times can be similarly randomly perturbed. The higher the random 

error, the more widely distributed traffic will be to loading (or unloading) points around the zone. 

The lower the random error, the greater the likelihood that route choice will favor a small number 

of centroid connectors in the zone, leaving some centroid connectors unused.  

To encourage a wider distribution of traffic among loading points in a zone, in general centroid 

connectors were assigned travel times of five minutes. Specific centroid connectors were sometimes 

assigned travel times greater than or less than that to encourage or discourage use of a 
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particular centroid connector relative to others serving the same centroid. Additionally, the 

centroid connector travel time error, which is defined as a percentage of the centroid connector 

travel time, was set to be 50%. This means that, for example, any given driver in the model may 

perceive the travel time on a centroid connector with a 5-minute travel time to be between 2.5 

and 7.5 minutes. The high error is meant to allow for enough variance to overcome the delay that 

might be experienced at a traffic signal immediately downstream of the loading point from the 

centroid connector. This way, the choice of centroid connector would not be entirely dominated by 

the delays experienced on the links in the immediate vicinity of the centroid. 

3.1.4 User A at I-15 Express Lanes 

The I-15 Express Lanes are parallel lanes along I-15 that run from Sahara Boulevard to Silverado 

Ranch Boulevard. Drivers enter and exit the express lanes only at specific locations. The choice to 

use the Express Lanes is modeled as a stochastic shortest path model seeking to minimize travel 

time. When there are parallel routes and the travel times are similar, such as those represented 

by either using the express lanes or not using the express lanes, it is difficult for the model to 

distribute vehicles between the two routes in a realistic manner.  

To address this issue, we designated 75% of all vehicles as User A vehicles and reserved the I-15 

Express Lanes for User A vehicles. User A vehicles are eligible to use the express lanes but can 

also choose to use the general purpose lanes instead. This ensured that the demand for the 

Express Lanes would not exceed the capacity of the lanes but also preserved the ability of the 

route choice model to select paths for vehicles. 

3.2 Simulation-Based Dynamic Traffic Assignment 
The principal advantage of DTA over traditional static assignment is the detailed treatment of the 

way congestion builds and subsides over time and in varying locations. When and where 

congestion develops owes largely to the way trip departures are distributed over the period of 

interest.  

Route choice behaviors are central to the DTA model, and hence, central to the calibration of the 

model. Before considering the fit between model volumes according to the DTA and volumes 

observed in the field, it is important to consider how the model volumes in the DTA are 

determined. 

The DTA model volumes are ultimately decided by the route choice decisions that drivers make, 

which are a function of departure time and expected travel conditions in the network. The 

expected travel conditions emerge from the route choice and consequent congestion patterns that 

arise collectively from the route choices of all travelers in the model. In order for reasonable route 

choices to be simulated, drivers must have knowledge of the congested, or loaded, travel times 

they expect to experience during their trip. Those travel times are not known a priori and thus are 

estimated from a microscopic traffic simulation of the period of interest (e.g., AM, PM).  

Thus, a microscopic simulation of the complete period is executed iteratively, with the method of 

successive averages (MSA) applied to output travel times and turning delays between iterations. 

The route choices of each run are a function of the travel times simulated and averaged over 
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prior runs. The primary objective of this iterative DTA framework is to equilibrate route choices 

such that drivers cannot switch to alternate paths and improve their travel times, a condition of a 

form of User Equilibrium (UE), when the model is sufficiently converged. 

The travel times are averaged in order to smooth them over the iterations to prevent inefficient 

and counter-productive switching back and forth between good and bad routes from one 

iteration to the next. The DTA runs until it has converged to a target gap, defined as the percent 

root mean square error (RMSE) between the travel times and delays of the previous iteration and 

the travel times and delays of the current iteration, or until a maximum number of iterations is 

reached. 

Generally, however, the maximum number of iterations rather than the target gap is relied upon 

as the stopping criterion in the application of the simulation-based DTA. Because the simulation 

model is a stochastic Monte Carlo simulation (i.e., each simulation is initiated with a different 

random seed and will produce variable results) and because vehicle trips are integer (i.e., they 

cannot be divided into tiny fractions as they are in the static traffic assignment methods), target 

gaps of the order of magnitude expected of high-quality static traffic assignments may not be 

achieved. However, many static models may be neither well-converged nor very accurate with 

respect to counts. 

Given that it is only the trend, not the absolute value, in the target gap that is relevant in the 

simulation-based context, the only matter of relevance is that the DTA be run until the target gap 

cannot be further reduced. In the application of the simulation-based DTA, convergence was 

generally deemed to be sufficient in about 50 iterations. 

After performing a DTA, paths used in the model can easily be browsed, reviewed, and checked 

for reasonableness. Routes observed visually between OD pairs and passing through selected 

critical links all satisfy a priori expectations. Unreasonable routes are filtered out of the set of 

route choices through the DTA iterations. 

Not only are poor route choices generally eliminated in the DTA, but route choices vary 

appropriately by departure time. The route choices are stochastic, dynamic route choices such that 

every driver perceives travel times differently from every other driver and the average travel 

time that drivers expect on a given link varies depending on the time of arrival at the link along 

the path. Travel times are represented in the model in a piece-wise linear fashion from the 

midpoint of one time interval to the next. Thus, the expected travel time on a link varies 

continuously across time rather than discontinuously as in a histogram.  

3.3 Dynamic Origin Destination Matrix Estimation (DODME) 
Once a DTA has been run and travel times and turning delays estimated, simulations can be run to 

determine how well the simulated volumes and speeds on road segments in the study area match 

the counts and speeds in each 15-minute interval. The DTA is followed by application of Dynamic 

Origin-Destination Matrix Estimation (DODME), a process which simulates the full peak period, 

computes a relative root mean square error (RMSE) across the complete set of count and speed 

locations at 15-minute intervals, scores every trip on how well the counts and speeds are matched 
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at the count and speed locations it passed in the 15-minute interval in which it passed them, and 

performs one of four actions on trips that score most poorly: 

1. Removal of the trip 

2. Clone of the trip 

3. Shift in trip departure time one 15-minute interval prior 

4. Shift in departure time one 15-minute interval later 

Conditions can be placed on the kinds of trips that can be removed, cloned, or shifted to constrain 

the DODME and impose human intelligence on the automated procedure. 

 

Figure 3-1. Illustration of the Dynamic Origin-Destination Matrix Estimation (DODME) Process 

In each application of the DODME, numerous iterations are run, and the demand is adjusted in 

ways that are likely to improve the match with the counts. When the demand is judged to have 

changed significantly, the DTA is run again to update the expected travel times and turning 

delays and to achieve consistency between the changes in demand and congestion patterns on 

which route choices are based.  

The DTA and DODME were thus applied iteratively until no further improvement could be 

achieved in the overall relative RMSE. 

3.4 Calibration Results 
Segment volumes and speeds in 15-minute intervals from the model were compared to available 

traffic data (as described in Section 2.5 Traffic Count Data and Section 2.6 Speed Data) to 

assess the goodness of fit of the model.  

Simulate

Compute RMSE

Score individual trips 
based on match to 15-

minute counts and speeds

For the lowest-scoring 
trips, remove, clone, or 

shift the departure time by 
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Percent Root Mean Square Error (%RMSE) is often used in statistical analysis to compare 

simulated volumes with traffic counts. %RMSE reflects differences between model volumes and 

traffic counts on individual links (versus differences in the aggregate sums) and also provides 

information on the magnitude of the error relative to the counts. In the context of comparing 

model flows and counts, %RMSE values are usually between 10% and 100%. Low %RMSE values 

typically reflect model volumes that are very similar to traffic counts while high %RMSE values 

reflect the opposite. The complete %RMSE results are summarized below in Table 3-1. 

 %RMSE Count 

AM     

All 31.1% 11,536 

Freeways 23.8% 3,408 

Arterials 34.4% 6,416 

PM   

All 29.9% 23,544 

Freeways 25.8% 6,880 

Arterials 29.4% 13,216 

Table 3-1. %RMSE and percent error threshold summary 

To further support the DTA model’s goodness of fit with the count data, the DTA model volumes 

are compared to the traffic counts for all roads in Figure 3-2 through Figure 3-3. In these 

scatterplots, the x-value of each point represents the 15-minute traffic count volume and the y-

value represents the 15-minute model volume. If the model volumes were always equal to the 

traffic counts, all points would lie directly on the diagonal dotted line. Points that lie below the 

diagonal line are count locations where the model volume was lower than the traffic count. Points 

that lie above the diagonal line are count locations where the model volume was higher than the 

traffic count. The scatterplots demonstrate reasonably good agreement between assigned 

volumes and counts with the simulated volumes overall being slightly lower than traffic counts. 
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Figure 3-2. A scatter plot comparing AM DTA model volumes and AM traffic counts on all roads 

 
Figure 3-3. A scatter plot comparing PM DTA model volumes and PM traffic counts on all roads 

Figure 3-4 through Figure 3-5 make the same comparison between model volumes resulting from 
the DTA and traffic counts for major arterials only. 
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Figure 3-4. A scatter plot comparing AM DTA model volumes and AM traffic counts on major arterials only 

 
 Figure 3-5. A scatter plot comparing PM DTA model volumes and PM traffic counts on major arterials only 

Finally, Figure 3-6 through Figure 3-7 make the same comparison between model volumes and 
traffic counts for freeways only. 
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Figure 3-6. A scatter plot comparing AM DTA model volumes and AM traffic counts on freeways only 

 
 Figure 3-7. A scatter plot comparing PM DTA model volumes and PM traffic counts on freeways only 

3.5 TransDNA Model Calibration 
TransDNA is a mesoscopic simulation-based DTA model that shares its time-varying demand input 

needs with microscopic models such as the TransModeler DTA. In addition, the calibration of 

mesoscopic DTA models involves the estimation/adjustment of supply-side inputs and speed-

density parameters. Supply calibration of a mesoscopic simulation model involves the specification 

of speed-density functions and capacities by link class. 

The OD demand for Las Vegas was obtained from the calibrated micro-simulation model 

developed in TransModeler. The route choice coefficients, speed-density functions and capacities 

y = 0.9632x - 15.408
R² = 0.9714

0

500

1,000

1,500

2,000

2,500

3,000

0 500 1,000 1,500 2,000 2,500 3,000

S
im

ul
a
te

d
 V

o
lu

m
e

Count

AM PEAK (7-9 AM): FREEWAYS

y = 0.9308x - 24.975
R² = 0.9708

0

500

1,000

1,500

2,000

2,500

3,000

0 500 1,000 1,500 2,000 2,500 3,000

S
im

ul
a
te

d
 V

o
lu

m
e

Count

PM PEAK (2-6 PM): FREEWAYS



 
 

 

Calibration Page 25 

are the defaults provided in TransDNA. These parameters have been chosen based on our 

literature review as well as Caliper’s own calibration based on field sensor data. 

A sample of the model’s fit to observed traffic count data is shown below, for the AM peak (7:00-

9:00). Each chart compares the observed count (on the horizontal axis) to the corresponding 

output from the model (on the vertical axis) for a 15-minute time interval within this peak. The red 

dotted line represents perfect fit while the blue dotted line is the linear regression through the 

points. While these represent a reasonably accurate model, it should be noted that further 

calibration (especially on the OD demand side) will be beneficial to the model. 
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4.0 Validation 

Once the calibration process was completed, the TransModeler DTA model was validated by 

comparing simulated travel times to Google travel times. The goal of validation was to establish 

goodness of fit between simulated trip times from the model and those estimated by Google for 

a large sample of OD pairs distributed throughout the region.  

As discussed in Section 2.7, Google travel time data were queried for a typical spring day, 

Wednesday, April 10, 2019. Ideally, travel time data would be obtained for 2015, the 

calibration year of the model, for validation. However, historical travel time data were not 

available, and Google’s Directions API can only be queried for future dates, though its results are 

based on historical data.  

Simulated travel times were obtained by producing dynamic skim matrices of the entire network, 

which summarize the simulated travel times by departure interval for every OD pair. 

During the AM peak period, Google travel times were obtained for four 15-minute departure 

periods: 7:00 AM, 7:30 AM, 8:00 AM, 8:30 AM. The Google travel times are compared to the 

simulated travel times in Figure 4-1 through Figure 4-4. 

During the PM peak period, Google travel times were obtained for eight 15-minute departure 

periods: 2:00 PM, 2:30 PM, 3:00 PM, 3:30 PM, 4:00 PM, 4:30 PM, 5:00 PM, 5:30 PM. The 

Google travel times are compared to the simulated travel times in Figure 4-5 through Figure 

4-12. 

Each chart displays the equation for the regression line that best fits the data as well as the 

coefficient of determination R2, a statistical measure of how closely the data fit to the regression 

line. Similar to the charts in Section 3.4, if the simulated travel times were always equal to the 

Google travel times, all points would lie directly on the diagonal dotted line, the slope of the line 

would be 1.0, and the R2 value, which is a statistical measure of how closely the data fit to the 

regression line with the given slope, would be 1.0. Points that lie below the diagonal line are trips 

whose simulated travel time were shorter than the travel times predicted by Google. Points that 

lie above the diagonal line are trips whose simulated travel time were greater than the Google 

travel times. The charts illustrate that, in almost all periods, the simulated times fit quite tightly 

around the diagonal line, the R2 values are quite high, and the slopes are close to 1.0. 
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Figure 4-1. A scatter plot comparing AM DTA model and Google travel times: 7:00 AM 

 
Figure 4-2. A scatter plot comparing AM DTA model and Google travel times: 7:30 AM 
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Figure 4-3. A scatter plot comparing AM DTA model and Google travel times: 8:00 AM 

 
Figure 4-4. A scatter plot comparing AM DTA model and Google travel times: 8:30 AM 
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Figure 4-5. A scatter plot comparing PM DTA model and Google travel times: 2:00 PM 

 
Figure 4-6. A scatter plot comparing PM DTA model and Google travel times: 2:30 PM 
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Figure 4-7. A scatter plot comparing PM DTA model and Google travel times: 3:00 PM 

 
Figure 4-8. A scatter plot comparing PM DTA model and Google travel times: 3:30 PM 
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Figure 4-9. A scatter plot comparing PM DTA model and Google travel times: 4:00 PM 

 
Figure 4-10. A scatter plot comparing PM DTA model and Google travel times: 4:30 PM 
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Figure 4-11. A scatter plot comparing PM DTA model and Google travel times: 5:00 PM 

 
Figure 4-12. A scatter plot comparing PM DTA model and Google travel times: 5:30 PM 

 
 

y = 0.9197x - 1.513
R² = 0.8917

0

10

20

30

40

50

60

70

0 10 20 30 40 50 60 70

S
im

ul
a
te

d
 T

ra
ve

l 
Ti

m
e
s 

(m
in

)

Google Travel Times (min)

Google vs. Simulated Travel Times - 5:00 PM

y = 0.7758x - 0.0954
R² = 0.8115

0

5

10

15

20

25

30

35

40

45

50

0 10 20 30 40 50

S
im

ul
a
te

d
 T

ra
ve

l 
Ti

m
e
s 

(m
in

)

Google Travel Times (min)

Google vs. Simulated Travel Times - 5:30 PM



 

Page 36 Model Application Guidance 

  

5.0 Model Application Guidance 

5.1 Choosing the Right DTA for Your Analysis 
When you wish to use DTA to analyze a project or scenario, it is important to choose the right DTA 

– the microscopic simulation-based DTA in TransModeler or the mesoscopic simulation-based DTA 

in TransDNA – for the application at hand. The choice will depend in large part on two broad 

questions, ideally asked in the following order of priority: 

What operational sensitivity is needed to perform the analysis effectively? 

What time and resources are available to perform the analysis? 

First and foremost, if the project involves traffic control (i.e., traffic signal or ramp metering), 

intelligent transportation systems (ITS), or advanced traffic demand management strategies 

(ATMS), then the microsimulation-based DTA will provide the better treatment of operating 

conditions and hence the better tool for the analysis. Similarly, if the project entails significant 

freeway improvements that will alter merging or weaving operations, then the microsimulation will 

also provide the more accurate quantification of the benefits because mesoscopic models adopt a 

more aggregate approach to capturing the merging and weaving interactions that are so critical 

to traffic flow on freeway facilities. A user’s guide for DTA with TransModeler is provided in 

Section 6.0. 

Secondly, if the analysis calls only for a quick approximation of the project’s benefits, for instance 

to test feasibility or to reduce a larger set of competing alternatives to a smaller set to be studied 

in greater detail subsequently, then the mesoscopic DTA in TransDNA is the recommended choice 

for its lower setup and running times relative to the microscopic DTA in TransModeler. A user’s 

guide for DTA with TransDNA is provided in Section 7.0. 

5.2 Microsimulation of Smaller Subareas in TransModeler 
It is worth noting that if a particular analysis involves a relatively localized project – for instance 

the reconfiguration of an interchange or intersection geometry or even a widening project along 

a corridor – then a microsimulation-based analysis can be cost-effective and will provide the 

better (i.e., more accurate) analysis. However, running the regional DTA may not be appropriate. 

Rather, it is advised that a smaller study area be extracted from the regional model and used for 

the analysis. You can select links in the Links layer and export them to a new simulation database. 

When you do so, TransModeler will prompt you to export signal timings for the subarea at that 

time. To extract an estimate of the demand for the same selection set of links, choose Simulation > 

Options and check, Report Subarea O-D and Dynamic Skim Data, and choose the selection set from 

the Selection drop-down list. Then, run a simulation to produce the subarea OD matrix. If a high 

degree of confidence in the analysis is needed (i.e., the analysis will support an investment 

decision or engineering design and not simply answer a planning question), the subarea model 

should undergo calibration and validation to refine the data exported for the subarea to improve 

the subarea model’s fit with observed conditions, just like any microsimulation study. 
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5.3 Creating OD Matrices for Future-Year Scenarios 
There is no established practice for estimating traffic demand for future years, but several 

methods have been proposed in the research literature and used in practice. These methods are 

generally referred to as pivot-point methods because a calibrated base-year matrix is used to 

pivot from unadjusted trip tables produced by a travel demand model for a forecast year Vf to 

adjusted trip tables for the forecast year Vf,adj based on a relationship between the unadjusted 

trip tables produced by the travel demand model for a calibrated base year Vb and the trip 

tables calibrated more tightly for the simulation model in the base year Vb,sim. 

The simplest pivot model applies a correction to the unadjusted forecast demand Vf based on the 

ratio of the base year simulation demand Vb,sim to the unadjusted base year demand Vb: 

𝑉𝑓,𝑎𝑑𝑗 = 𝑉𝑓
𝑉𝑏,𝑠𝑖𝑚
𝑉𝑏

 

A useful synthesis of pivot methods can be found in the Australasian Transport Research Forum 

2012 Proceedings. 

Standard matrix operations in TransCAD and TransModeler can be performed using commands in 

the Matrix menu in order to compute adjusted forecast trip tables. In the context of the 

TransModeler and TransDNA DTA models, Vb,sim represents the calibrated trip tables that are 

input to those models, Vb represents the base year (i.e., 2015) trip matrix produced by the RTC 

travel demand model in TransCAD, and Vf represents a forecast year trip matrix also produced 

by the travel demand model. 

Further, because the forecast volumes Vf produced by the travel demand model will be static, 

single-period demand, the same temporal distribution reflected in the dynamic (i.e., 15-minute) 

trip matrices in the DTA models may be assumed. 

Because there is no standard practice for development of dynamic forecast trip tables for 

regional DTA models, it is recommended that the RTC consider further research activity to 

ascertain which pivot methods work best and/or to explore the various pivot methods in projects 

to which the DTAs are applied in order to gain direct project experience with the alternative 

methods. 

https://www.atrf.info/papers/2012/2012_Daly_Fox_Patruni_Milthorpe.pdf
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6.0 TransModeler DTA User’s Guide 

This User’s Guide for the DTA model provides information about the model as well as guidance on 

how the RTC and its partners can apply the model. 

6.1 Introduction to Projects and Scenarios 
A simulation project in TransModeler is a collection of files representing street, traffic demand, 

and signal timing data organized together by a simulation project file (.SMP). A simulation project 

file corresponds with a fixed representation of the roadway geography and geometry stored in 

a simulation database. For the given geometry stored in the simulation database, a simulation 

project can contain any number of scenarios. Scenarios may represent different years, times of 

day, signal timings, and other inputs that you may vary in order to study the performance of the 

transportation system under different conditions.  

To evaluate the performance of the transportation system with a different roadway geography 

or geometry, a new simulation database would be built and a new simulation project 

referencing the new simulation database would be created. 

A project that has signalized intersections requires only three inputs: a simulation database, one 

or more trip matrices, and a signal timing plan file (.TMS). However, TransModeler supports a wide 

variety of additional applications, from incident management to managed lanes analysis, which 

may require additional optional inputs. 

6.1.1 The RTC Simulation Project 

There is one project included with the operations model, and it contains two scenarios: 

1. AM – Simulation from 6:00 AM to 9:00 AM, which includes the two AM peak hours from 

7:00 AM to 9:00 AM plus one hour of warm-up. 

2. PM – Simulation from 1:00 PM to 6:00 PM, which includes the four PM peak hours from 

2:00 PM to 6:00 PM plus one hour of warm-up. 

 To Open the Simulation Project 

1. Choose File > Open. TransModeler will open the File Open dialog box. 

2. Browse to the folder where you have copied the model. 

3. Locate and highlight the simulation project RTC DTA.SMP. 

4. Click Open. TransModeler will open the project and display it in a map window. 

6.1.2 Scenarios 

The Project Settings dialog box is where scenarios are created and managed in TransModeler. 

The Project Settings include a list of scenarios, the parameters that define each scenario (e.g., the 

start and end time of the period to be simulated), and the various input files used in each 

scenario. The input files used in the DTA model are described in Table 5-1.  
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Input File Extension Description 

Simulation Database DBD A geographic file representing the road network and geometry (i.e., RTC DTA.DBD) 

Trip Matrix MTX A matrix file storing the origin-to-destination volumes of drive alone, SR2, SR3, single 
unit trucks, and tractor trailer trucks produced by the regional planning model (e.g., PM 

DA.MTX) 

Signals TMS A signal timing plan file containing the phasing and timing parameters that govern 
signal operations at signalized intersections and ramp meters (i.e., RTC SIGNAL 

TIMINGS.TMS).  

Historical Travel 
Times 

BIN A table storing the average 15-minute travel times for all road segments in the 
simulation database on which route choices are, in part, based (e.g., AM HISTORICAL 

TRAVEL TIMES.BIN) 

Turning Delay Table BIN A table storing the average 15-minute turning movement delays for all turning 
movements in the simulation database on which route choices are, in part, based (e.g., 
AM TURNING DELAYS.BIN) 

Parameters XML A parameter file containing all of the driver behavior parameters that were modified 
as part of the calibration and validation of the operations model (i.e., PM 

PARAMETERS.XML) 

Table 6-1. Input files defining a model scenario 

 To Change Scenarios in the Simulation Project 

1. Choose the name of the scenario from the Project > Scenario menu command. 

OR 

1. Choose Project > Settings. TransModeler will open the Project Settings dialog box. 

2. Choose the name of the scenario from the Current drop-down list. 

3. Click OK. 

 To Review the Parameters and Input Files Defining a Scenario 

1. Choose Project > Settings. TransModeler will open the Project Settings dialog box. 

2. Choose the name of the scenario whose parameters and input files you want to review from 

the Current drop-down list. 

3. Click the Setup, Network, Input, Output, Routing, Parameters, and Options tabs to review the 

various parameters and input files defining the scenario. 

4. To read more about the parameters and input files, click F1 on the keyboard. 

TransModeler will open the Project Settings help topic in the TransModeler help files. 

5. In the Project Settings dialog box, click Cancel to close the dialog box. 

 To List All Input Files and Their Full File Paths For a Scenario 

1. Choose Project > Scenario > File Manager from the menu system. 

 To Create a New Scenario in a Simulation Project 

1. Choose Project > Settings. TransModeler will open the Project Settings dialog box. 

2. Choose the scenario that you want to simulate with and without the development demand 

from the Current drop-down list. 

3. Click . TransModeler will open the Create New Scenario dialog box. 
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4. Enter the scenario name (e.g., PM with Managed Lanes), and click OK. TransModeler copies 

the scenario you chose in Step 2, duplicating all of its parameters and input files, and 

makes it the current scenario. 

5. Click OK. TransModeler adds the new scenario and makes it the active scenario in the 

project. 

6. If you want to save the new scenario in the project, choose File > Save. 

6.1.3 Map Layers 

When you open the simulation project in TransModeler, a map window is opened displaying the 

map layers making up the simulation database. These include the following layers: 

▪ Link and node layers defining the streets and intersections 

▪ Segment and lane layers representing detailed street cross-sections and lane geometries 

▪ A TAZ layer displaying the traffic analysis zones from the planning model 

▪ Centroid and centroid connector layers representing origins, destinations, and points of 

access to the streets 

▪ Signal and sensor layers representing traffic signals and traffic signal detectors 

▪ Vehicles 

▪ Several count layers showing the geographic locations of field traffic counts 

Other layers can be added to the map to aid visualization and model development and review. 

These may include water boundaries (e.g., lakes and rivers), aerial imagery, and other 

geographic data. TransModeler supports a wide variety of geographic file formats, from ESRI 

Shapefiles to aerial imagery formats such as JPEG, GeoTIFF, and MrSID.  

 To Add or Remove Map Layers 

1. Choose Map > Layers from the menu system. TransModeler will open the Map Layers 

dialog box. 

2. To remove a layer, highlight it in the list, and click Drop Layer. 

3. To add a new layer, click Add Layer, choose the type of file you want to add from the 

drop-down list on the File Open dialog box, locate the file, and click Open. 

4. To hide or show a layer in the map, highlight the layer and click Hide Layer or Show Layer, 

respectively.  

5. To read more about changing the contents of a map, click F1 on the keyboard. 

TransModeler will open the Changing the Contents of a Map help topic in the TransModeler 

help files. 

6. In the Map Layers dialog box, click Close to close the dialog box. 

 
Note that you might find it more convenient to manipulate the contents of a map using the Display 

Manager, which gives you immediate access to all of the layers in the map and to their style, 

labeling, and other customizable display settings. To read more about working with the Display 

Manager, hold the mouse over Map > Display Manager Toolbar in the menu system, and click F1 on 

the keyboard. 
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6.2 How to Perform a DTA in TransModeler 
The DTA model can be run on various Build and No Build scenarios to evaluate the performance 

of alternative or proposed projects. The DTA can be run either from a cold start, in which drivers 

assume free flow conditions in the first iteration, or from a warm start, in which the solution of a 

previous DTA informs the route choice decisions of drivers in the first iteration. While a cold-start 

DTA should generally be run for a greater number of iterations, it is still an open research 

question whether fewer iterations are sufficient for a regional model having the scale and 

complexity of the RTC DTA model. 50 iterations are generally found to be sufficient for achieving 

reasonable convergence (i.e., when experienced trip times cease to change substantially with 

further iteration) whether beginning the DTA with a cold or warm start. 

When significant changes to the network are made, for instance to simulate the impacts of a 

managed lanes project, a cold start is generally advised. A warm start is advised when modest 

changes are made to the network or to the input trip data. 

When the DTA is completed, either when it is stopped manually or when the maximum number of 

iterations is reached, output travel time and turning delay tables describing congestion at the UE 

condition in the network will be created and opened. These files should be referenced as the 

HISTORICAL TRAVEL TIMES.BIN and TURNING DELAYS.BIN tables in the Routing tab of the Project Settings 

for the corresponding scenario before the scenario is simulated to produce performance 

measures. 

 To Run the DTA Model in TransModeler from a Cold Start 

1. Open the DTA simulation project RTC DTA.SMP.  

2. Choose Simulation > Options. 

3. Choose Dynamic Traffic Assignment from the Run frame. 

4. A Target Gap of 0.5% can be retained as the default. The DTA should not converge to this 

gap. Rather, the DTA should be stopped manually when the convergence measure ceases 

to decline or at a maximum number of iterations. 

5. Enter 50 in the Maximum Iterations box. 

6. Check the Start from free flow box. 

7. Accept all other default parameters, and click OK. 

8. Choose Simulation > Begin to start the DTA. 

9. If you are prompted for the output folder and historical travel time and turning delay table 

file names, provide them and click OK. TransModeler will start the DTA. 

10. To stop the DTA when the convergence measure is no longer declining, choose Simulation > 

End. TransModeler will open the historical travel time and turning delay tables. 

 To Run the DTA Model in TransModeler from a Warm Start 

1. Open the DTA simulation project RTC DTA.SMP. 

2. Choose Project > Settings and ensure that the historical travel time and turning delay 

tables of a prior DTA solution are chosen on the Routing tab.  

3. Open the Simulation Toolbar by clicking .. 

4. Click   to open the Simulation Options dialog box. 
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5. Choose Dynamic Traffic Assignment from the Run frame. 

6. A Target Gap of 0.5% can be retained as the default. The DTA should not converge to this 

gap. Rather, the DTA should be stopped manually when the convergence measure ceases 

to decline or at a maximum number of iterations. 

7. Enter 50 in the Maximum Iterations box. 

8. Uncheck the Start from Free Flow box. 

9. Accept all other default parameters and click OK. 

10. Click  to start the DTA. 

11. If you are prompted for the output folder and historical travel time and turning delay table 

file names, provide them and click OK. TransModeler will start the DTA. 

12. To stop the DTA when the convergence measure is no longer declining, click .. 

TransModeler will open the historical travel time and turning delay tables. 

6.3 How to Maintain and Update the Model 

6.3.1 Road Editing 

As and the region’s surface transportation system is upgraded, To preserve the DTA model’s 

usefulness and readiness for project work, the road network in the DTA model should periodically 

be updated to reflect any roadway improvement projects that are completed in the region. The 

following directions give a brief overview on road editing in TransModeler. 

Road editing is primarily done with tools on the Road Editor. The list of tools in the Road Editor is 

available in the Help topic, “Editing Simulation Databases,” and is also copied below in Table 

6-2. 

Changes to a road network are made in an “editing buffer” where they are pending edits until 

you click Commit , at which point the changes are saved to the simulation database. To undo all 

changes made in an editing buffer, click the Cancel . There is no undo option for road edits 

after changes in a buffer are committed, but every change that can be made with the road 

editing tools can be reversed. A link that has been split into two can be rejoined, a lane connector 

that has been deleted can be re-added, a turn bay that has been added can be removed by 

deleting the lane and rejoining segments, etc. Actions using the road editing tools are not 

complete until the editing buffer in which they are taken is committed. 
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Button Name Function 

 
Select Select a feature for editing 

 
Edit Properties Edit the properties of a feature 

 
Edit Attributes Edit the attributes of a feature 

 
Add Link Add a new link to the network 

 
Delete Segment Delete a link or segment from the network 

 
Join Join two links or two segments together 

 
Split Split a single link into two links, or a single segment into two segments 

 
Add Lane Add a new lane to a segment 

 
Delete Lane Delete a lane from a segment 

 
Add Turn Bay Add a left (or right) turn bay at an intersection 

 
Add Channelized Turn Add a channelized right (or left) turn link at an intersection 

 
Add Acceleration Lane Add an acceleration lane at an on-ramp junction 

 
Add Deceleration Lane Add a deceleration lane at an off-ramp junction 

 
Add Bus Pull-out Add a bus pull-out lane  

 
Add Lane Connector Add a new lane connector between two lanes 

 
Delete Lane Connector Delete a lane connector 

 
Move Stop Bar Move the position of the stop bar along the connector 

 
Move Yield Position Move the position where vehicles yield to opposing through movements 

 
Move Bend Points Move bend points on a connector to change its shape 

 
Add Centroid Connector Add a new centroid connector 

 
Delete Centroid Connector Delete a centroid connector 

 
Add Sensor Add a new sensor 

 
Delete Sensor Delete a sensor 

 
Add Crosswalk Click in the map to add a pedestrian crosswalk  

 
Delete Crosswalk Click on a pedestrian crosswalk to delete it 

 
Add/Remove Median Divide the two sides of a two-way street into separate one-way links 

 
Add/Remove TWLTL Convert an existing lane into a shared center two-way left turn lane (TWLTL) 

 
Convert One-Way Convert a two-way street to one-way or a one-way street to two-way 

 
Add Roundabout Create a roundabout 

 
Smooth Curvature Smooth the curvature of a segment (add or move shape points along a smooth 

curve) 

 
Reverse Direction Reverse the direction of a one-way street 

 
Edit Elevation Edit the elevation profile of a link or segment 

 
Label Elevation Label the elevations of a segment’s shape points in the map 

 
Remove Elevation Labels Removes the elevation labels in the map 

 
Cancel Abandon the changes made in the current edit buffer 

 
Commit Save the changes in the current edit buffer to the simulation database 

 
Road Editor Configuration Change the Road Editor Configuration 

Table 6-2. Road Editing Tools in TransModeler 

Step-by-step instructions for using all of the road editing tools can be found in TransModeler Help 
(Help > TransModeler Help) in the section “Editing Streets and Intersections.” Below you will find 
two brief instructions for adding new links and lanes – common actions when you want to add a 
street or implement a widening project, respectively, in the model. 
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 To Add a Link 

1. Choose Project > Road Editing > Road Editor or click  on the Project toolbar to open the 

Road Editor. 

2. To set basic parameters for the new link, click  to open the Road Editor Configuration 

dialog box. Otherwise, skip to Step 12. 

3. Click the New Features tab. 

4. To make the new link to intersect with the links that it crosses, check New Links Intersect. 

5. To have a smooth curve be calculated automatically as you add the link, check Click Curves. 

6. To make the new link one way, check One Way. 

7. To change number of lanes on the right (AB) side, enter the number of lanes in the Lanes on 

Right edit box. 

8. To change number of lanes on the left (BA) side, enter the number of lanes in the Lanes on 

Left edit box. 

9. To change default elevation of the new link, enter an elevation in the Elevation edit box. 

10. To choose a road class for the new link, choose a road class name from the Road Class 

drop-down list.  

11. Click OK. 

12. Choose . 

13. Click at the starting point of the link. 

14. To add one or more shape points, move the mouse to the next point and click. 

15. To end the line, double-click on the endpoint. TransModeler displays the new link with 

endpoints and intermediate shape points. 

16. Click  to commit your changes or  to cancel them. 

 To Add a Lane 

1. Choose Project > Road Editing > Road Editor or click  on the Project toolbar to open the 

Road Editor. 

2. If you want to enable or disable the option to have lane connectors updated automatically, 

click  to open the Road Editor Configuration dialog box. Otherwise, skip to Step 6. 

3. Click the Options tab. 

4. Check or uncheck Update lane connectors automatically. 

5. Click OK. 

6. Choose . 

7. Click on the segment to which you want to add a lane. TransModeler inserts a new lane at 

the clicked location. 

8. Click  to commit your changes or  to cancel them. 

6.3.2 Road Classification 

Road classification is important not only for establishing speed limits in the model but also for 

ensuring proper driving behaviors, namely as driving behaviors relate to merging onto a 

freeway, regulating right of way at intersections, and gap acceptance entering roundabouts. 

Road class ranking determines priority between turning movements where signage or signals do 

not explicitly regulate right of way, for instance for left turning movements from a major to a 

minor street. TransModeler uses a road class’ priority rank to determine which is the major and 
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which is the minor street (Help Topic “Displaying and Editing Intersection Turning Movement 

Priority”). Speed limits vary by road class in TransModeler and can be reviewed or changed for 

all road segments sharing the same road class. 

The road classification parameters affecting microscopic simulation are briefly summarized in 

Table 6-3. For more information, please see the Help topic “Road Class Definition.” 

Parameter Function 

Priority A numeric code used to determine right of way between 
two at intersections where no signals or signs are present 

Special Type A type used to further distinguish different types of 
facilities: 
    None - No special type 
    Freeway - Link type is freeway (excluding on/off ramps) 
    Roundabout - Link is part of a rotary or roundabout 
    Rail - Link is for use only by trains 
    Ramp - Link type is a ramp 

Desired Speed Distribution The desired speed distribution governing driver compliance 
with the speed limit 

Speed Limit Default speed limit 

Free Flow Speed The speed used to determine free flow travel times, which 
are assumed when calculating route choices when no 
historical travel times or turning delays are provided, and 
to impose a lower bound on the perceived travel time on a 
road segment even when historical travel times and turning 
delays are provided 

Travel Time Perception Error Percentage error used to randomize segment travel times 
when calculating the shortest path in the route choice model 
(only used when the Stochastic Shortest Path route choice 
method is chosen) 

Saturation Flow The saturation flow used as the base saturation flow rate in 
passenger car equivalents (PCE) per hour per lane when 
performing signal optimization and to compute lane group 
capacities and delays at signalized intersections in 
mesoscopic and macroscopic simulation. 

Table 6-3. Road Classification Parameters 

 To Review Road Classes and Speed Limits 

1. Go to Parameters > Road Classification > View Summary 

2. A Road Class Summary dataview will open where you can review all road classes and 

associated attributes, including the speed limit.  

 How to Edit Road Classes and Speed Limits 

1. Go to Parameters > Road Classification > Edit Road Classes 

2. In the Name drop-down list, choose a road class. 

3. On the General tab, edit Priority, Special Type, Saturation Flow, Free Flow Speed, and Travel 

Time Perception Error.  

4. On the Microscopic tab, edit Speed Limit and Desired Speed Distribution. 

 How to Change the Road Class of a Link 

1. Make Links the active layer. 

2. Click on the Info button . 

3. Click on a link to open an Info dataview. 
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4. Scroll down to the Class attribute. 

5. Click in the drop-down list and choose the desired road class. 

6.3.3 Traffic Count and Speed Data 

Directional traffic count and speed data is stored in the Segments layer. Table 6-4 lists the fields 

associated with traffic count and speed data and their descriptions.  

Name Description 

AB Short Term Count ID ID of Count sourced from NDOT 2015 short term count archives; AB direction 

BA Short Term Count ID ID of Count sourced from NDOT 2015 short term count archives; BA direction 

AB ATR Count ID ID of Count sourced from NDOT continuous counters; AB direction 

BA ATR Count ID ID of Count sourced from NDOT continuous counters; BA direction 

AB SNTS Count ID ID of Count sourced from Southern Nevada Traffic Study performed by HDR for 
NDOT; AB direction 

BA SNTS Count ID ID of Count sourced from Southern Nevada Traffic Study performed by HDR for 
NDOT; BA direction 

Count Comment Comments on count 

Count Source ID NDOT ATR or Short Term Count Source ID; Southern Nevada Traffic Study Count 
Source ID 

Count Street Name of the street on which the count is located 

Count Exit Name of exit associated with the count, where applicable 

Count Location Location of count 

Count Date Date of count 

CNT_XXXX_AB 15-minute count in the AB direction where XXXX represents the time in military 
format (e.g., CNT_1415_AB is the count from 2:15PM-2:30PM in the AB direction) 

CNT_XXXX_BA 15-minute count in the BA direction where XXXX represents the time in military 
format (e.g., CNT_0100_BA is the count from 1:00AM-1:15AM in the BA direction) 

CNT_0700-0900_AB Sum of counts between 7:00AM-9:00AM; AB direction 

CNT_0700-0900_BA Sum of counts between 7:00AM-9:00AM; BA direction 

CNT_1400-1800_AB Sum of counts between 2:00PM-6:00PM; AB direction 

CNT_1400-1800_BA Sum of counts between 2:00PM-6:00PM; BA direction 

SPD_XXXX_AB Average speed over a 15-minute period in the AB direction where XXXX 
represents the time in military format (e.g., CNT_0830_AB is the count from 
8:30AM-8:45AM in the AB direction) 

SPD_XXXX_BA Average speed over a 15-minute period in the BA direction where XXXX 
represents the time in military format (e.g., CNT_1645_BA is the count from 
4:45PM-5:00PM in the BA direction) 

SPD_0700-0900_AB Average speed between 7:00AM-9:00AM; AB direction 

SPD_0700-0900_BA Average speed between 7:00AM-9:00AM; BA direction 

SPD_1400-1800_AB Average speed between 2:00PM-6:00PM; AB direction 

SPD_1400-1800_BA Average speed between 2:00PM-6:00PM; BA direction 

TAZ_ATYPE_CBD 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = CBD 

TAZ_ATYPE_External Connec 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = 
External Connec 

TAZ_ATYPE_Resort Corridor 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = Resort 
Corridor 

TAZ_ATYPE_Rural 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = Rural 

TAZ_ATYPE_Suburban 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = 
Suburban 

TAZ_ATYPE_Urban 1 if count is located in or on the boundary of a TAZ where ATYPE_NAME = Urban 

TAZ_KFACT_DIST_X 1 if count is located in or on the boundary of K-Factor District X, where X ranges 
from 0 to 24 

Count_Weight_AM Weight assigned to count in the AM period 

Count_Weight_PM Weight assigned to count in the PM period 

Table 6-4. Description of Count Fields in Segments Layer 
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 To Review and Update Traffic Count Data 

1. Make Segments the working layer by choosing it in the drop-down list on the Standard 

toolbar and click on  to open a dataview. Alternatively, right-click on the Segments layer 

in the Display Manager and choose New Dataview.  

2. Scroll to the desired field and review the data. 

3. You can also click on the Info button  and click on a segment to open an Info dataview to 

review the data for a specific segment. 

The current traffic counts are largely from 2015 with a few counts from 2017 (namely, those from 

the Southern Nevada Traffic Study, or SNTS). In the future, as additional traffic count data 

become available, they can be added as additional fields to the Segments layer.  

 To Add Fields for New Traffic Count Data 

1. Choose Dataview > Table > Modify or click  on the Standard toolbar to display the 

Modify Table dialog box.  

2. Click Add Field to add a new field. If you add a field and either start it or end it with “AB,” 

then immediately add another field, TransModeler will automatically name the new field 

the same as the previous field but change “AB” to “BA.” For example, if you click Add Field,  

name it “ExampleAB,” and then click Add Field again, the new field will automatically be 

named “ExampleBA.” 

3. Choose a Type from the drop-down list. 

4. Click Move Up and Move Down to reorder fields. You can highlight multiple rows before 

clicking Move Up and Move Down to move fields up and down in a group. 

5. Rename a field by clicking in the Field Name edit box and typing a new name. If you add 

new traffic count fields, you may want to append the year to the field name to 

differentiate counts from one year from another year.  

6. See the Help topic “Modifying the Structure of a Table” for other ways to modify the 

table. 
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7.0 TransDNA DTA User’s Guide 

This section serves as a TransDNA DTA user’s guide for RTCSNV. It describes the files, setup, and 

options for running mesoscopic DTA using the calibrated model created by Caliper. While the 

contents of this user guide deal with the specifics of running the Las Vegas models, a 

comprehensive description of TransDNA’s mechanics, parameters, and options will be found in the 

TransDNA chapter of the forthcoming Travel Demand Modeling with TransCAD 9 user’s guide. 

TransDNA is a mesoscopic traffic simulation engine that works directly on TransCAD line layers. It 

can be accessed via the TransDNA menu in TransCAD 9.0. 

The Las Vegas models cover both the AM and PM peaks, with an hour appended at the beginning 

to account for loading time leading up to the start of the peak period in the RTCSNV TransCAD 

model: 6:00-9:00 AM and 1:00-6:00 PM time periods. Separate sets of inputs have been 

created for each of these time periods, though they share some common files such as the line layer 

and network files. 

This user guide covers: 

▪ The organization and brief description of the relevant files 

▪ A description of the road link classifications adopted by the model 

▪ Steps to run TransDNA 

▪ Viewing and working with standard output files 

▪ Basic scenario analysis options 

7.1 TransDNA File Organization 
The TransDNA folder contains two folders and five key files. The Demand folder contains OD 

matrices, trip tables and historical travel time/turning delay tables for both the AM and PM 

periods. The Output folder is empty and will hold all output files generated by TransDNA. The 

demand and other files are enumerated and described below. 

7.1.1 The Line Layer 

The file “Links 2018-11-01.dbd” is the line layer representing the Las Vegas road network. It is a 

standard geographic file containing centerline geography and attributes of the nodes and links. 

The extent of the network is shown in Figure 7-1.  
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Figure 7-1. The Las Vegas line layer for TransDNA 

A closer view of the link layer is shown in Figure 7-2. 

 
Figure 7-2. A zoomed-in view of the Las Vegas line layer in TransDNA 
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The link and node attributes of relevance to mesoscopic simulation are: 

▪ Control Type 

▪ Travel Lanes  

▪ HOT Lanes 

▪ Added Lanes on Left 

▪ Left bay Length (in feet) 

▪ Added Lanes on Right 

▪ Right Bay Length (in feet) 

▪ Road Class 

▪ Free Flow Speed (in mph) 

▪ Capacity per Lane (in vph) 

▪ Travel Time Variability 

7.1.2 The Network File 

The file Las_Vegas_Network_File.net is a standard TransCAD network file that specifies the 

subset of links of relevance to the simulation. It also includes the selection of nodes that are 

centroids, as well as turning movement penalties to be used during the dynamic routing process. 

7.1.3 The Workspace File 

The Las_Vegas.wrk file is a TransCAD workspace. Opening this file will open the line layer in a 

map window and associate the network file with this map. The workspace is a convenient and 

quick way of loading multiple files into TransCAD in a single step. 

7.1.4 The Demand Files 

The Demand sub-folder contains a set of OD matrices for each of the AM and PM simulation 

periods. The time period appears as a prefix to each file. The DA, SR2, SR3, TRK – ST and TRK – 

TT files are matrix files containing the TAZ-to-TAZ vehicle trip volumes for drive-alone (single 

occupancy), shared ride (double or higher occupancy) and truck (short and trailer) vehicles. These 

files will be disaggregated into a list of individual vehicle trips at the start of the DTA. During this 

stage, each trip is assigned additional attributes as necessary, such as driver value of time, driver 

group and vehicle class. TransDNA will save this trip list to a TransCAD binary table (*.BIN), which 

may then be directly loaded for future simulations without having to re-compute the trip 

characteristics and paths from the OD matrices. 

7.1.5 The TransDNA Project Files 

A TransDNA project file has a .DNA extension and is used to store settings pertaining to 

TransDNA assignments. Two such files, LasVegas_AM.DNA and LasVegas_PM.DNA, have been 

created for the AM and PM models, respectively. A project file can be loaded into TransCAD to 

read in the pre-generated settings for the desired scenario. The settings can then be reviewed, 

modified and saved through the Scenario Manager dialog box (Section 7.3). 
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7.2 Road Link Classification and Speed-Density Functions 
TransDNA needs to know each link’s type so that its performance under various traffic conditions 

can be accurately inferred during simulation. The AB_RoadClass and BA_RoadClass fields in the 

line layer contain numeric codes pertaining to various road classes, whose definitions can be 

found by choosing TransDNA-Parameters > Edit Road Classes.  

 
Figure 7-3. The Road Classification Dialog Box in TransDNA 

Each road class is associated with a speed-density function that is used to compute the average 

vehicle speed for the prevailing traffic density. Many mathematical function forms have been 

proposed in the literature for the speed-density function. While four such functions are available 

in TransDNA, the Greenshields model is the most widely used and well-tested. Refer to the Travel 

Demand Modeling with TransCAD user manual for details about these functions. 

Each speed-density equation is associated with a set of parameters that determine its shape, and 

consequently, its response and sensitivity to evolving traffic density. The Road Classification dialog 

box displays the default parameters for each speed-density function form, including the 

Greenshields function. In addition, TransDNA comes with default parameters for several link 

types, calibrated against real-world speed and density (detector occupancy) data. Click on Road 

Classes in the left pane to view these parameters and road classes (Figure 7-3). 
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Figure 7-4. Speed-Density Model Parameters in TransDNA 

The AB_RoadClass and BA_RoadClass values are matched with the IDs in the ID column in Figure 

7-4 to map the links to their relevant TransDNA speed-density functions.  

7.3 How to Perform a DTA in TransDNA 
A DTA is run in TransDNA by loading a TransDNA Please refer to the TransDNA chapter in the 

TransCAD planning manual for a more detailed description of the various simulation options. 

 To Run the DTA Model in TransDNA from a Cold Start 

1. Choose File > Open Workspace and choose Las_Vegas.wrk. If the workspace has been 

deleted, you can recreate it by opening the line layer (Links 2018-11-01.dbd), dragging 

the network file (Las_Vegas_Network_File.net) onto the open map, and saving the 

workspace through the File > Save Workspace As menu. 

2. TransDNA is accessed through the TransDNA menu. Choose TransDNA > Scenario Manager 

to open the Scenario Manager dialog box. 

3. Click Load and browse out a TransDNA project file (.DNA). The AM and PM files have 

already been created for this dataset. TransCAD will load the settings in the dialog box. 
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Figure 7-5. The Scenario Manager Dialog Box in TransDNA 

4. The Settings tab contains information pertaining to the high-level parameters of the 

scenario. 

a. The Name and Folder boxes indicate the scenario name and the location of the 

data folder for this scenario. 

b. The Time Period frame indicates the start and end times of the simulation. 

c. The Simulation Options frame lets you choose the simulation mode and its 

associated parameters. The calibrated dataset is configured for Dynamic Traffic 

Assignment (DTA). One-shot simulation and batch simulation may also be 

performed once the model has already been calibrated. 
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5. The Network tab contains information about centroids and link attributes: 

a. The Network frame displays the current active network (.NET) file. This is only for 

information. If you wish to change the network file, you can either drag the new 

file onto the map or use Networks/Paths > Drop followed by Networks/Paths > 

Settings to add a new file. You can also create a network file from scratch using 

Networks/Paths > Create. 

b. Use the Link Fields frame to view the line layer attributes that are currently being 

used in the scenario. 

6. The Input tab contains information about the travel demand, signals and tolls. 

7. The Output tab lets you specify the folder location for all TransDNA output files. You can 

also enter the time interval width for output data collection and choose settings for the 

dynamic color theme for visual inspection during a simulation run. 

8. The Routing tab allows you to choose historical link travel time and turning movement 

delay tables if they exist from a previous TransDNA run. 

9. The Parameters tab allows you to choose the node discharge model to be used. If you 

have made changes to the speed-density functions or road classes, you can choose those 

modified parameter and road class files. You can also control the vehicle movement and 

network state update step sizes if you wish to test the impacts of these parameters in 

running time and model accuracy. 

10. The Options tab lets you slow down the speed of the simulation (if necessary), fix the 

random seed (for example, if you wish to reproduce identical results across runs) and set 

the units of measurement. 

11. Click OK. TransCAD will open the TransDNA toolbar (7.4). 

12. Click the play button  and choose the output file location(s) to start the DTA.  

 To Run the DTA Model in TransDNA from a Warm Start 

1. Choose TransDNA > Scenario Manager to open the Scenario Manager dialog box. 

2. Click the Routing tab. 

3. Click the  and choose a historical travel time table produced from an earlier DTA 

(Section 7.5.3). 

4. Click OK. The settings will be processed to ensure consistency before the TransDNA toolbar 

is displayed at the bottom of the TransCAD window: 

5. Click the play button  and choose the output file location(s) to start the DTA.  

7.4 The TransDNA toolbar 
You can use the TransDNA toolbar to control the simulation and interact with the network links 

(Figure 7-6). 

 
Figure 7-6. The TransDNA Toolbar 

▪ Use the pause toggle button  to temporarily halt the simulation. Press the button again to 

resume the simulation. 
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▪ Press the stop button  to terminate the current run. 

▪ Press the Stopwatch button  to have the simulation pause when it reaches a specific time 

in the future. 

▪ The Time window indicates the current temporal position of the simulation. 

▪ The Time Factors windows indicate the desired and actual running time speeds, represented 

as a multiple of the real-time clock. An actual time factor of 20, for instance, indicates that 

the simulation is running 20 times faster than real-time. 

▪ The  and  buttons allow you to slow down and speed up the simulation. 

▪ The four Vehicles windows show the number of vehicles in the network, vehicles in queue, 

completed trips and remaining trips respectively. 

▪ The Chart Link Info button  allows you to click on a link to query its traffic state evolution 

from the start of the simulation. If you have made multiple runs, you can use the Choose Run 

button  to set the specific run for which you want to query the links. 

▪ The Show Warnings button  opens a browser window with any warnings generated 

during the simulation. You can review this file to trouble-shoot network, path and demand 

issues. 

7.5 Working with TransDNA Outputs 
TransDNA displays its DTA outputs in three different ways. 

7.5.1 Visualizing Network Performance Dynamically in TransDNA 

You can interact with the live simulation via the map by viewing the dynamic color theme. You can 

pan and zoom the map to focus on areas of interest (Figure 7-7). 
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Figure 7-7. A Dynamic Color Theme in TransDNA 

Use the scenario manager to change the settings for the theme display. For instance, you can 

control the refresh rate of the theme to change the frequency with which the theme is updated 

with the latest simulation results. By default, the theme refreshes every 5 seconds (Figure 7-8). 
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Figure 7-8. Dynamic Theme Settings in the TransDNA Scenario Manager 

Click the Settings button in the Map Themes frame to make more detailed theme setting choices. 

You can choose different fields to determine the thickness and color of the theme. The width is set 

to a fixed width by default. Use the Fields drop-down list in the Width frame to choose a field. 

The color theme displays the speed index by default. The speed index of a link is its prevailing 

speed divided by its free-flow speed, which normalizes the speed to fall between 0 and 1. This 

speed index is potentially easier to interpret than speed, as it provides a comparison to the 

maximum possible speed on the link. 

Use the Fields drop-down list in the Color frame to choose from speed, density, and speed index 

(i.e., speed divided by free flow speed). You can also choose the color palette by choosing the 

colors for the two ends of the range and one via point (Figure 7-9). 
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Figure 7-9. Dynamic Theme Settings During Assignment 

The Dynamic Traffic Assignment dialog box displays the progress of the DTA by iteration (Figure 

7-10). 
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Figure 7-10. DTA Progress by Iteration in TransDNA 

Each row contains the iteration number, convergence metric and the run time for that iteration. 

Convergence is measured as a consistency between the input travel times to drivers at the start of 

the iteration, and those they experienced during the simulation. The run time estimates the total 

time taken for each iteration, including both the network loading and the process of updating 

individual drivers’ route choices before the start of the next network loading. 

Click the Chart Convergence button  to chart the progress of the DTA (Figure 7-11). 
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Figure 7-11. Chart of DTA Convergence by Interval and Iteration 

Click the Save to File button  to save the numerical convergence data to a table (.BIN file). 

7.5.2 Charting Individual Link Performance in TransDNA 

You can also query a link’s evolving traffic pattern, obtaining charts of its traffic flow, speed and 

density up to the current time. Choose the Chart Link Info button  in the TransDNA toolbar 

(Section 7.4), and then click on the desired link in the map to generate a set of three charts for 

that link (Figure 7-12). 
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Figure 7-12. A Chart Depicting Link Performance in TransDNA 

7.5.3 Reviewing DTA Output Files in TransDNA 

TransDNA also writes out various files that you can review and process for further analysis. These 

files are written into a time-stamped sub-folder within the output folder: 

▪ A table of convergence metrics by departure time interval and for each DTA iteration, stored 

in DTA Convergence.bin. 

▪ Time-dependent outputs of link performance (volume, speed, density, spillback, travel time 

and delay), stored in LinkInfo_{iteration number}.bin. 

▪ Time-dependent outputs of turning movement travel times and delays, stored in 

NodeInfo_{iteration number}.bin. 

Once the DTA run is completed, the following files are written into the main output folder: 

▪ The final time-dependent link counts and travel times, in Historical Travel Times.bin. 

▪ The final turning movement counts and delays, in Historical Travel Times_.bin. 

▪ The final LinkInfo file, copied into Link Volumes.bin. 

▪ The final NodeInfo file, copied into Turning Volumes.bin. 

Historical Travel Times.bin and Historical Travel Times_.bin can be used to warm-start a new DTA 

from the results of a prior DTA run (Section 7.3). 
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7.6 Scenario Analysis with TransDNA 
TransDNA currently supports a range of popular scenario analyses including changes to the 

demand, number of left-turning, through and right-turning lanes, turn bay lengths, free-flow 

speeds, capacities and link performance functions. Given the mesoscopic nature of the simulation, 

the modeler must map/reduce specific scenarios to more aggregate but direct model inputs such 

as those listed above. An expansion of TransDNA’s feature set is currently in progress and will be 

released as they become available for general use in the software.  

 


